Results 1 to 3 of 3

Thread: JVC 40LTC550

  1. #1
    Lifetime Subscriber
    Join Date
    Dec 2010
    Location
    accrington lancs
    Posts
    1,522


    JVC 40LTC550

    The worst set I have ever seen. Anyway told by customer picture for half a second then backlights go out. Ok. You assume back light failure. Plug it in, sure enough, Logo for half a second. Goes off. Confidently remove back. That's a pain. Only inner section comes off. Suss the rest and removed bezel. Outer and inner screens to reveal Leds and plug it in. All lamps lit correctly. I'm thinking it's not a current issue because of this. Do led sets use OVP in the backlight circuitry? Every led set I've ever repaired has had one or more Leds faulty.
    All posts are spell checked and legibility proofed for easy comprehension.

  2. #2
    Forum Subscriber ianone's Avatar
    Join Date
    Apr 2012
    Location
    8 St Lukes Buildings Hart St Bridge Southport PR8 6BP
    Posts
    7,969


    Re: JVC 40LTC550

    If that is a Chinese chassis a strong possibility of software corruption,very little info on it as probably a Currys or Argos special.
    Still love repairing all stuff electronic,but what can compare to a sunny day.

    Regards
    Ian

  3. #3
    Lifetime Subscriber Contrast John's Avatar
    Join Date
    Dec 2010
    Location
    Hull East Yorkshire
    Posts
    2,059


    Re: JVC 40LTC550

    Hi Tony

    is that model number LT-40C550 ?

    If so Mo has a main board

    http://www.microtech-av-services.co....rd-303c4201056
    Regards

    John.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •